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1   Preface

Thank you for purchasing CrossCore® Embedded Studio (CCES), Analog Devices development software for Black-

fin®, Blackfin+®, SHARC, and SHARC+® processors.

Purpose of This Manual
The CrossCore Software Licensing Guide describes how to manage licenses for CCES software.

Intended Audience
The primary audience for this guide is anyone who is working with CCES, a licensed product from Analog Devices.
It describes the product licensing options, installation, and activation. The guide also includes the troubleshooting
and FAQ sections for licensing issues.

Manual Contents
The manual consists of:

• Chapter 1, Licensing Overview

Describes the available CCES license types and licensing options.

• Chapter 2, Activating a License

Details how to install and activate a CCES license.

• Chapter 3, Administering a Corporate Domain License

Describes how to install and administrate a corporate CCES domain license.

• Appendix A, Troubleshooting

Explains commonly encountered error messages and provides answers to frequently asked questions.

• Appendix B, Licensing Support

Describes how to contact Analog Devices regarding licensing issues.

Preface
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What’s New in this Manual
This is Revision 1.9 of the CrossCore Software Licensing Guide. In this revision, a new operating system and require-
ments are added to the overview section.

Technical Support
You can reach Analog Devices processors and DSP technical support in the following ways:

• Post your questions in the processors and DSP support community at EngineerZone®:

http://ez.analog.com/community/dsp

• Submit your questions to technical support directly at:

http://www.analog.com/support

• E-mail your questions about processors, DSPs, and tools development software from CrossCore Embedded Stu-
dio or VisualDSP++®:

Choose Help > Email Support. This creates an e-mail to processor.tools.support@analog.com and automatical-
ly attaches your CrossCore Embedded Studio or VisualDSP++ version information and license.dat file.

• E-mail your questions about processors and processor applications to:

processor.tools.support@analog.com

processor.china@analog.com

• Contact your Analog Devices sales office or authorized distributor. Locate one at:

http://www.analog.com/adi-sales

• Send questions by mail to:
Analog Devices, Inc.
One Technology Way
P.O. Box 9106
Norwood, MA 02062-9106
USA

Product Information
Product information can be obtained from the Analog Devices website and CrossCore Embedded Studio online
help system.

Analog Devices Website
The Analog Devices website, http://www.analog.com, provides information about a broad range of products—ana-
log integrated circuits, amplifiers, converters, and digital signal processors.

What’s New in this Manual
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To access a complete technical library for each processor family, go to http://www.analog.com/processors/techni-
cal_library. The manuals selection opens a list of current manuals related to the product as well as a link to the
previous revisions of the manuals. When locating your manual title, note a possible errata check mark next to the
title that leads to the current correction report against the manual.

Also note, MyAnalog.com is a free feature of the Analog Devices website that allows customization of a web page to
display only the latest information about products you are interested in. You can choose to receive weekly e-mail
notifications containing updates to the web pages that meet your interests, including documentation errata against
all manuals. MyAnalog.com provides access to books, application notes, data sheets, code examples, and more.

Visit MyAnalog.com to sign up. If you are a registered user, just log on. Your user name is your e-mail address.

EngineerZone
EngineerZone is a technical support forum from Analog Devices. It allows you direct access to ADI technical sup-
port engineers. You can search FAQs and technical information to get quick answers to your embedded processing
and DSP design questions.

Use EngineerZone to connect with other DSP developers who face similar design challenges. You can also use this
open forum to share knowledge and collaborate with the ADI support team and your peers. Visit http://
ez.analog.com to sign up.

Notation Conventions
Text conventions used in this manual are identified and described as follows. Additional conventions, which apply
only to specific chapters, can appear throughout this document.

Example Description

File > Close Titles in bold style indicate the location of an item within the CrossCore Embedded Studio
IDE’s menu system (for example, the Close command appears on the File menu).

{this | that} Alternative required items in syntax descriptions appear within curly brackets and separated by
vertical bars; read the example as this or that. One or the other is required.

[this | that] Optional items in syntax descriptions appear within brackets and separated by vertical bars; read
the example as an optional this or that.

[this, …] Optional item lists in syntax descriptions appear within brackets delimited by commas and ter-
minated with an ellipsis; read the example as an optional comma-separated list of this.

.SECTION Commands, directives, keywords, and feature names are in text with letter gothic font.

filename Non-keyword placeholders appear in text with letter gothic font and italic style format.

NOTE: NOTE: For correct operation, ...

A note provides supplementary information on a related topic. In the online version of this
book, the word NOTE: appears instead of this symbol.

EngineerZone
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Example Description

CAUTION: CAUTION: Incorrect device operation may result if ...

CAUTION: Device damage may result if ...

A caution identifies conditions or inappropriate usage of the product that could lead to undesir-
able results or product damage. In the online version of this book, the word CAUTION: appears
instead of this symbol.

ATTENTION: ATTENTION: Injury to device users may result if ...

A warning identifies conditions or inappropriate usage of the product that could lead to condi-
tions that are potentially hazardous for devices users. In the online version of this book, the
word ATTENTION: appears instead of this symbol.

Notation Conventions
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2   Licensing Overview

This chapter describes licensing options available for CrossCore Embedded Studio (CCES) 2.x.x users.

The following topics are covered:

• Supported Operating Systems

• System Requirements

• Note to VisualDSP++ Users

• Licensing Terminology

• License Types

• License Expiration and Subscription

• License Locking Options

• Licensing Options Summary

• Obtaining a License Serial Number

• Locating License Serial Numbers

• Getting a PC Ready for License Activation

If you have any questions related to CCES licenses or licensing, contact Technical Support.

NOTE: The software license agreement can be found in the Docs folder of the CCES installation.

Supported Operating Systems
CCES 2.8.0 supports the following operating systems:

• Windows® 10 Pro or Enterprise (32 and 64-bit)

• Windows 8.1 Pro or Enterprise (32 and 64-bit)

• Windows 7 (SP1 or later) Professional , Enterprise, or Ultimate (32 and 64-bit)

• Ubuntu 14.04 (32-bit)

Licensing Overview
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• Ubuntu 16.04 (32-bit)

Warning: Windows users may experience User Access Control (UAC) related errors if the software is installed into a
protected location, such as Program Files or Program Files (x86). We recommend installing the soft-
ware in a non-UAC-protected location.

Warning: Prior to installation, ensure your machine is up-to-date with relevant Windows updates from Microsoft.
CrossCore Embedded Studio relies upon the Microsoft Universal C Runtime from VisualStudio 2015 and can si-
lently fail to install if your machine is out-of-date.

System Requirements
Verify that your PC has these minimum requirements for the CCES 2.8.0 installation:

• 2 GHz single-core processor; 3.3 GHz dual-core or better recommended

• 4 GB RAM; 8 GB or more recommended

• 2 GB available disk space

• One open USB port

NOTE: A faster disk drive or SSD decreases the build time, especially for a large amount of source files. 8 GB of
RAM or more substantially increases the IDE performance.

NOTE: For proper viewing of documentation under Windows, Internet Explorer 9 or greater is recommended.

Note to VisualDSP++ Users
CrossCore Embedded Studio is a new Analog Devices product: the graphical user environment and full develop-
ment tool chain for digital signal processor applications. Although some aspects of CCES licensing are familiar to
VisualDSP++ users, VisualDSP++ licenses themselves cannot be used with CCES.

Licensing Terminology
License Installation

License installation is the process of entering valid license information into CCES. A license that has been entered
into CCES but not activated immediately is said to be “installed”.

License Registration

License registration is the process during which a user informs Analog Devices that a license has been installed. Li-
cense registration results in a validation code.

License Activation

System Requirements
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License activation is the process of unlocking the functionality of a CCES product by registering your serial number
with Analog Devices. Activation includes license installation, registration, and validation, all in one step.

License Validation

License validation is the process of entering an Analog Devices validation code into CCES. License validation com-
pletes the activation of an installed license.

License Types
Tool chain Evaluation Licenses

A tool chain evaluation license provides 90 days of use on activation after which it expires and becomes permanently
disabled.

If installed but not activated, this license allows 10 days of operation (grace or trial period) before it expires and
becomes disabled. The license can be re-enabled by activation.

A tool chain evaluation license can be activated once on a particular machine.

Add-in Evaluation Licenses

Certain add-ins (CCES software components), such as Micrium µC/OS-III™ Real-Time Kernel for CrossCore Em-
bedded Studio, also have an evaluation license. Once activated, this license lets you install the add-in. You can install
versions of the add-in with release dates up to 90 days after activation (see License Expiration and Subscription).

An add-in evaluation license can be activated once on a particular machine.

Full Licenses

A full license does not expire once it has been activated.

Activation starts the license subscription, determining which product versions are enabled based on release date (see
License Expiration and Subscription). Subsequent full licenses, called maintenance licenses, can be purchased at a re-
duced cost to renew the subscription term for an additional year.

If installed but not activated, a full tool chain license allows 10 days of operation before it expires and becomes disa-
bled. The license can be re-enabled by activation.

• A full tool chain license can be activated a limited number of times, which allows the user to move the installa-
tion to a different machine.

• A full license for an add-in must be activated to allow the add-in to install. There is no grace period with this
type of license.

EZ-KIT Licenses

An EZ-KIT License behaves as a full license but supports only one EZ-KIT board. This means that the license only
allows development for the EZ-KIT board for which it is licensed. The license does not allow the use of the simula-
tor when debugging applications. The developer must use the emulator and their EZ-KIT board to debug applica-
tions.

License Types
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License Expiration and Subscription
License expiration and subscription are related but distinct terms. License expiration refers to overall viability of the
license. For example, a tool chain evaluation license provides 90 days of use after activation, then expires. A full
license, on the other hand, does not expire after activation. See License Types for more information.

License subscription determines what product versions you can use with a license. The subscription starts when the
license is activated and ends at the end of the subscription interval. Products released before the subscription ends
can be used with the license. Products released after a subscription ends cannot be used with the license.

A subscription example: A full license with a one year subscription interval is activated on June 1, 2015. This license
can be used with products that have release dates up to and including June 1, 2016. To use products with release
dates beyond this date, the user needs to activate a new license. Note that you continue to use products that were
released before the subscription ends even after the subscription itself has expired. The subscription determines
whether or not newer versions of the product may be used.

To renew a subscription, a maintenance license must be purchased and activated. Contact your Analog Devices sales
office or authorized distributor. Locate one at http://www.analog.com/adi-sales.

License Locking Options
Node-Locked Licenses

Occasionally referred to as a single-user license or a per user license, a node-locked license is locked to the machine
host ID of a specific host computer and provides a single license “seat”. Once installed, the product runs on that one
computer only.

The machine host ID typically refers to the Media Access Control (MAC) address of the network card or mother-
board. CCES uses MAC addresses as host IDs and supports the use of multiple MAC addresses in its licensing
scheme.

Corporate Domain Licenses

Corporate domain licenses lock to a network domain name, such as *.subdomain.yourcompany.com.

A license locks to one specific type of host ID. The license locking option cannot be changed.

Licensing Options Summary
Licensing controls the operation and installation of the CCES 2.8.0 features and components. The licensing options
are summarized in the following tables.

License Expiration and Subscription
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Table 2-1: Licensing Options for CCES Tool Chain

Type Prefix Evaluation - EVAL EZ-KIT - EZK Full - ADI
Applies to Full tool chain operation Full tool chain operation for spe-

cific EZ-KIT Board, except sim-
ulator which is not supported

Full tool chain operation

(For add-ins, see the following
table.)

Expiration 90 days Permanent Permanent

Processor family Blackfin and SHARC Blackfin or SHARC, depending
on the EZ-KIT

Blackfin and SHARC

Locking options Node-locked Node-locked Node-locked or corporate do-
main

Subscription None 1 year 1 year

Table 2-2: Licensing Options for CCES Add-ins

Type Prefix Evaluation - EVAL Full - ADI
Applies to µC/OS-III add-in installation Add-ins installation

(For tool chain operation, see the previous
table.)

Expiration Permanent Permanent

Processor family Blackfin and SHARC Blackfin and SHARC

Locking options Node-locked Node-locked

Subscription 90 days 1 year

For example, an evaluation license for the CCES development tool chain EVAL-CCES-XXXX-XXXX-XXXX-
XXXX-XXXX-XXXX-XXXX:

• Has a serial number prefix of EVAL
• Allows use of the full development tool chain

• Expires 90 days after activation

• Allows use of Blackfin and SHARC processors

• Is node-locked to the MAC address (physical address of the network card) of a specific computer

• Does not have a subscription interval

An EZ-KIT license for the CCES development tool chain, EZK-CCES-XXXX-XXXX-XXXX-XXXX-XXXX-
XXXX-XXXX:

• Has a serial number prefix of EZK
• Is permanent once activated

Licensing Options Summary
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• Allows use specific EZ-KIT it is licensed for

• Is node-locked to the MAC address of a specific computer

• Has a one-year subscription interval

A full license for the CCES development tool chain, ADI-CCES-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-
XXXX:

• Has a serial number prefix of ADI
• Is permanent once activated

• Allows use of Blackfin and SHARC processors

• Is node-locked to the MAC address of a specific computer or a corporate network domain name

• Has a one-year subscription interval

A full license for an add-in, such as Micrium µC/OS-III, ADI-[UCOS3]-XXXX-XXXX-XXXX-XXXX-XXXX-
XXXX-XXXX:

• Has a serial number prefix of ADI
• Is permanent once activated

• Allows use of Blackfin and SHARC processors

• Is node-locked to the MAC address of a specific computer

• Has a one-year subscription interval

Obtaining a License Serial Number
This section covers the following topics:

• Obtaining a Full License Serial Number

• Obtaining an EZ-KIT License Serial Number

• Obtaining an Evaluation License Serial Number

NOTE: An evaluation license (EVAL) can be upgraded to a full license (ADI).

Obtaining a Full License Serial Number

To obtain a full license:

1. Purchase a full license from:

• Analog Devices directly. Call (800)262-5645, 781-937-2384 or go to the buy online facility at
http://www.analog.com/en/content/buy_online/fca.html.

Obtaining a License Serial Number
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• Depending on your location, an Analog Devices local sales office or authorized distributor. To locate one,
go to http://www.analog.com/salesdir/continent.asp.

ADDITIONAL INFORMATION: A purchased copy of CCES is accompanied by an ADI serial number.

Obtaining an Evaluation License Serial Number

To obtain an evaluation license:

1. Install the CrossCore Embedded Studio software.

ADDITIONAL INFORMATION: CCES offers a tool chain evaluation license the first time it runs. CCES also
offers an evaluation license for a Micrium µC/OS add-in the first time you install µC/OS.

NOTE: An evaluation copy of CCES is accompanied by an EVAL serial number.

Obtaining an EZ-KIT License Serial Number

To obtain an EZ-Kit license:

1. Purchase a qualifying EZ-KIT evaluation board from:

• Analog Devices directly. Call (800)262-5645, 781-937-2384 or go to the buy online facility at
http://www.analog.com/en/content/buy_online/fca.html.

• Depending on your location, an Analog Devices local sales office or authorized distributor. To locate one,
go to http://www.analog.com/salesdir/continent.asp.

ADDITIONAL INFORMATION: A purchased copy of CCES and the EZ-KIT (EZK) serial number is accom-
panied with the evaluation board.

Locating License Serial Numbers
It is assumed that the CCES software is installed, licensed, and running on your computer.

1. To locate a CCES license serial number:

a. Choose Help > Manage Licenses.

The Manage Licenses dialog box appears.

Tip: Use the dialog box to look up information pertaining to CCES licenses installed on a computer and
perform various licensing tasks.

2. To copy a serial number of the license to the system clipboard:

a. Select the serial number.

b. Choose Copy serial number from the context menu.

Obtaining a License Serial Number
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3. To copy the entire license report to the system clipboard:

a. Click Report.

The License Report dialog box appears.

b. Click Copy.

ADDITIONAL INFORMATION: Choosing Help > Email Support automatically creates an e-mail message to
processor.tools.support@analog.com, generates, and attaches the product information report to the message.

Getting a PC Ready for License Activation
License activation requires TCP/IP network (Internet) access.

Ensure your PC is ready to activate a CCES license:

1. Connect your PC to the Internet.

2. Ensure that firewall settings allow interaction with the Analog Devices licensing server.

3. If your license is node-locked, ensure the computer has a valid MAC address:

a. On computers with Windows OS, you can view all current TCP/IP network configuration values by run-
ning the following command at the command prompt: ipconfig/all

Docking or undocking a laptop can affect the MAC addresses availability.

Licensing Support
If you still are experiencing a problem after trying to solve it using the information in this guide, contact Analog
Devices, Inc.

E-Mail Support

You can obtain support via e-mail as follows:

Registration Support:

Contact Registration Support if you have any problems with registering or validating your license serial number, or
if you have lost your license serial number. Use the following e-mail address:

processor.tools.support@analog.com.

Processor Tools Support:

For all other queries regarding CCES licensing, contact Processor Tools Support. Use the following e-mail address:

processor.tools.support@analog.com.

Getting a PC Ready for License Activation
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Tip: Choosing Help > Email Support automatically creates an e-mail message to the above address, generates, and
attaches the product information report to the message.

Information Required by Support

Before contacting Customer Support regarding a licensing issue, document the problem.

Prepare to communicate the following information:

• Software version provided by the Help > About CrossCore Embedded Studio dialog box

• License serial number(s) in question

• Contents of license.dat (if available)

• Screen captures of encountered error messages

Tip: Choosing Help > Email Support automatically creates an e-mail message to processor.tools.support@ana-
log.com, generates, and attaches the product information report to the message.

Licensing Support
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3   Activating a License

The chapter describes the processes of installing a license string (serial number) into the CCES Integrated Develop-
ment Environment (IDE) via the New License Wizard as well as activating the license. CCES licenses are defined in
Licensing Terminology.

The following topics are covered:

• Starting the New License Wizard

• Selecting a License Type

• Entering a License Serial Number

• License Activation Methods

• Activating a License in One Step

• Delayed License Activation

• Validating a License

Refer to the CCES online help for reference information about the IDE components related to software installation
and licensing.

Starting the New License Wizard
It is assumed that the CCES software is installed.

1. Start the New License Wizard:

• If CCES is run the first time, or a new licensed add-in product is installed:

ADDITIONAL INFORMATION:

a. Navigate to CrossCore Embedded Studio Environment via Windows Start menu.

A warning message appears.

b. Click Yes.

• If CCES is run the second time and thereafter:

Activating a License
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ADDITIONAL INFORMATION:

a. Choose Help > Manage Licenses > New.

The New License Wizard appears.

2. (Optional) Selecting a License Type.

Selecting a License Type
It is assumed that the New License Wizard is launched (see Starting the New License Wizard and the following fig-
ure).

Figure 3-1: New License Wizard: Select License Type Page

CCES license types are defined in License Types.

1. Depending on whether you want to evaluate or activate a CCES product, do one of the following:

• If you would like to evaluate a CCES product (do not have a serial number for a permanent/full license):

a. I do not have a serial number and would like to evaluate the product is selected by default.

Click Next.

The Select license activation method page appears.

b. Choose your license activation method (see License Activation Methods).

NOTE: You are bypassing the license installation step, while evaluating the CCES software, for 90 days.

• If you would like to activate a CCES product (have a serial number for a permanent/full license):

Selecting a License Type
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a. Select I have a serial number that I would like to activate.

b. Click Next.

The Enter your serial number page of the New License Wizard appears.

2. (Optional) Entering a License Serial Number.

Entering a License Serial Number
It is assumed that the Enter your serial number page of the New License Wizard is open (see Starting the New Li-
cense Wizard and the following figure).

Figure 3-2: New License Wizard: Enter your serial number Page

To enter a license serial number:

1. In Serial Number, enter the number exactly as it appears, including dashes.

Entering a valid serial number displays your computer’s host ID and enables the Next button.

2. Click Next.

The Select license activation method page appears.

3. (Optional) Choose your license activation method (see License Activation Methods).

License Activation Methods
The following sections describe the process of license activation, as defined in Licensing Terminology.

A license can be activated immediately or after a trial period. The license activation can be performed:

Entering a License Serial Number
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• In one step if your PC is on the TCP/IP network (Internet). This is the most convenient license activation
method, detailed in Activating a License in One Step.

• In three steps if your PC is not on the TCP/IP network. This method is referred to as delayed activation and
detailed in Delayed License Activation.

In step 1, you install the license. For tool chain licenses, this provides access to the entire CCES tool chain until
the specified license expiration date.

In step 2, you register the license. This results in the validation code sent back to you via e-mail.

In step 3, you validate the license (enter the validation code sent to you). This unlocks the trial period, making
the license permanent.

NOTE: Corporate domain licenses and node-locked licenses are installed in the same manner, but a license file
containing a corporate license can be distributed (Distributing a License File) to multiple computers on
the corporate domain. For more information about administering corporate domain licenses, refer to Ad-
ministering a Corporate Domain License.

Activating a License in One Step

If your computer has an Internet connection, to activate a license in one step is the most convenient method.

It is assumed that:

1. Your PC is ready for the one-step activation; see Getting a PC Ready for License Activation.

2. The license serial number is entered in the New License Wizard; see Entering a License Serial Number.

3. The Select license activation method page of the wizard is open (see Selecting a License Type), and Install and
activate a license on-line all in one step is selected (as in the following figure).

License Activation Methods
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Figure 3-3: Activating a License in One Step

If your computer does not have an Internet connection, or such a connection is isolated, select Install a temporary
license and then register it via website and choose the Delayed License Activation method.

To activate the license in one step:

1. Click Next.

The Prepare for one-step license activation page appears.

2. Fill in the form.

The required fields are marked by an * (asterisk).

3. Click Next.

The Prepare for one-step license activation (continued) page appears.

4. Complete the form.

5. Click Finish.

The Your license has been successfully activated message (in the following figure) concludes the one-step license
activation.

License Activation Methods
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Figure 3-4: Your license has been successfully activated Message

6. Click OK to return to the IDE.

You successfully registered and activated your copy of the CCES 2.x.x software. If you receive an error message dur-
ing this procedure, refer to Troubleshooting.

Delayed License Activation

The delayed activation enables a customer to use the CCES tool chain for a specified trial period; the license activa-
tion date is delayed.

NOTE: CCES add-ins also support delayed license activation. Once these licenses are activated, they permit add-in
installation.

It is assumed that:

1. The license serial number is entered in the New License Wizard; see Entering a License Serial Number .

2. The Select license activation method page of the wizard is open; see Selecting a License Type.

If your computer has access to the Internet and Analog Devices licensing server, install and activate the license in
one step. Keep the default selection, Install and activate a license on-line all in one step and refer to Activating a
License in One Step.

If your computer does not have access to the Internet or Analog Devices licensing server, to activate the license:

1. Select Install a temporary license and then register it via website (as in the following figure).

ADDITIONAL INFORMATION: 
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Figure 3-5: Delayed License Activation

2. Click Finish.

The License Registration Instructions Web page appears (see the following figure).

Figure 3-6: License Registration Instructions Page

The License Registration Instructions page indicates that your license is installed but not registered. At this
point, a CCES tool chain license provides 10 days of unrestricted tool chain use. The page describes how to
register your license, obtain a validation code, and complete activation of your license, with or without Internet
access.
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NOTE: Licenses for CCES add-ins install but are not valid until registered and activated.

3. Complete the registration process as instructed and submit the form.

Analog Devices processes your information and sends a validation code in email.

4. (Optional) Validating a License.

Validating a License
Once you receive a validation code for your CCES product from Analog Devices via email, complete the license
activation procedure.

It is assumed that the CrossCore Embedded Studio is installed and launched.

To permanently validate a license on a computer that is connected to the Internet:

1. Choose Help > Manage Licenses.

The Manage Licenses dialog box appears.

2. Select the serial number of the license that you want to validate.

Selecting a valid serial number enables the Validate command.

3. Click Validate.

The Enter Validation Code dialog box appears (see the following figure).

Figure 3-7: Enter Validation Code Dialog Box

4. In Validation code, enter the validation code sent to you.

ADDITIONAL INFORMATION: Prevent typos by copying and pasting the license string.

5. Click OK.

The successfully entered validation code results in a message indicating that a permanent license is created.

Validating a License
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6. Click OK.

The license serial number is added to the Manage Licenses dialog box. Note that the status icon next to the
license serial number has changed.

Search the online help for reference information about the IDE components related to software installation and li-
censing.
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4   Administering a Corporate Domain License

This chapter describes how to create and install license files based on a corporate domain address.

Rather than locking to individual MAC (Ethernet) addresses, a corporate domain license locks to a network domain,
such as *.subdomain.yourcompany.com. A license file containing a corporate domain license can be cop-
ied to multiple computers on the domain, potentially reducing overall administrative overhead.

The following topics are covered:

• Determining Your Corporate Domain

• Locating a Corporate Domain License

• Activating a Corporate License

• Distributing a License File

Determining Your Corporate Domain
This procedure applies to computers with Windows operating system.

1. View all current TCP/IP network configuration values by running the following command at the command
prompt: ipconfig/all
ADDITIONAL INFORMATION: The corporate domain is the value of the primary Domain Name System
(DNS) suffix. The corporate domain license is locked to this value, so all computers that use this license must
have the same corporate domain value. If the primary DNS suffix is blank, the computer is not on a domain,
and a corporate domain license cannot be used.

Locating a Corporate Domain License
• This procedure applies to computers with Windows operating systems listed in Supported Operating Systems.

• It is assumed that the CCES is installed on a computer that is on the corporate domain.

If you already have installed (entered) a license and want to locate the license folder, follow the procedure in Locat-
ing License Serial Numbers. The complete path to the license file is at the beginning of the report.
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The CCES installer creates a folder that holds license files on each computer.

1. Locate the license folder in <system drive>/ProgramData/Analog Devices/CrossCore
Embedded Studio.

ADDITIONAL INFORMATION: On some computers, the license folder may be a hidden system folder.

Activating a Corporate License
The process of activating a corporate domain license is similar to the process of activating a node-locked license.

1. Follow the instructions in one of the following procedures:

• Activating a License in One Step

• Delayed License Activation

ADDITIONAL INFORMATION: Validation codes for corporate domain licenses are sent via email, regardless
of the activation method.

Distributing a License File
It is assumed that:

• The CrossCore Embedded Studio software is installed on the target computers.

• The corporate domain license is obtained (see Obtaining a License Serial Number) and activated (see Activat-
ing a License) on one of the computers to be covered by the license.

To distribute a corporate domain license on each computer to be covered by the license, do the following:

1. (Optional) Back up, delete, or rename the existing license file.

ADDITIONAL INFORMATION: The License Report dialog box (Obtaining a Full License Serial Number)
provides the location of the folder that contains the license file.

2. From a computer on which the license is activated, copy the license.dat file into the license folder created
by the CrossCore Embedded Studio installer.

CrossCore Embedded Studio now runs on the target computers.

Activating a Corporate License
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5   Troubleshooting

This chapter provides answers to common licensing problems and includes the following sections:

• Frequently Asked Questions (FAQs)

• Installation Error Messages

• Installation Warning Messages

If you still have questions related to CCES licenses or licensing after reading this chapter, contact Technical Support
or Licensing Support.

Frequently Asked Questions (FAQs)
This section describes some common questions arisen during license installation and validation.

Question: I have lost my serial number. Where can I find it, or how do I get a replacement?

Answer: You can locate already installed serial numbers in the CCES IDE: Help > Manage Licenses. Refer to Locat-
ing License Serial Numbers for more information.

If you do not have CCES installed and licensed, e-mail Analog Devices with details of the person and company to
whom the serial number was originally registered. For more information, refer to Technical Support.

Question: I’ve just installed a tool chain evaluation license using the “Install a temporary license and then register it via
website” option of the New License Wizard. Now I get a message telling me that the license will expire in X days. I thought
licenses were permanent?

Answer: When evaluation licenses are installed this way, they have an initial grace period. An evaluation license runs
for 90 days after activation. In order to unlock the complete evaluation period, an evaluation license must be validat-
ed.

Full tool chain licenses installed via the Install a temporary license and then register it via website option of the New
License Wizard also have an initial grace period but become permanent when validated. Refer to License Activation
Methods for more details.
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Question: I’ve just installed a full license for a CCES add-in using the Install a temporary license and then register it via
website activation option of the New License Wizard. Now the status of the license shows as ‘Expired’. Doesn’t this license
have a grace period?

Answer: This type of license has no grace period: it must be validated to enable installation of its component. Refer
to License Types for details.

Question: What is the difference between license ‘expiration’ and license ‘subscription expiration’?

Answer: When a license is expired, it does not allow its products to be used at all. License subscription applies to
licenses that are not expired and allows product use based on a product release date. See Licensing Terminology for
more information.

Question: How do I transfer my license to a new machine?

Answer: Use the New License Wizard to activate your license on the new machine. If activation fails with a message
“The license has already been registered the maximum number of allowed times”, request a registration history update
via e-mail to processor.tools.support@analog.com. Include the serial number(s) in question.

Question: How can I find out my registration history? That is, how do I find out which machines my serial number(s) are
registered against?

Answer: To request an up-to-date registration history, send an e-mail with the serial number(s) in question to pro-
cessor.tools.support@analog.com.

Question: I’ve just installed a license using the Install a temporary license and then register it via website activation option
of the New License Wizard. The validation code that was e-mailed to me is being rejected. What could be the problem?

Answer: Validation codes are valid for a particular serial number and host ID combination. If you are trying to acti-
vate your serial number on a second computer, you will have to register it on the new computer in order to receive
the appropriate validation code. For more information, refer to License Activation Methods.

Question: Where is the license.dat file on my computer?

Answer: There is only one license.dat file for all CCES installs on a computer, and the file is located in the
license folder. The full path to the license file is given in the report generated by Help > Manage Licenses > Report or
by Help > Email Support.

NOTE: The license folder may be a hidden system folder on some computers.

Question: How do I install both a node-locked license and a corporate domain license on the same machine?
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Answer: Licenses of all types can coexist on the same machine. Use the New License Wizard to activate both licenses.

If you intend to install the corporate domain license on many machines, refer to Determining Your Corporate Do-
main.

Question: What limitations does an EZ-KIT license have?

Answer: An EZ-KIT license limits the developer to writing applications for the EZ-KIT Evaluation Board that the
license supports. For example, an ADSP-SC584 EZ-KIT license allows the developer to write applications only for
the ADSP-SC584 EZ-KIT Evaluation Board. In addition, the developer can only use the emulator or the debug
agent when debugging their applications. The simulator is not supported by an EZ-KIT license.

Installation Error Messages
This section describes some common error messages issued during license installation and validation.

Problem: A valid license could not be found.

Click Yes to install a license at this time.

Click No to close CCES.

Solution: This message appears the first time CCES starts up or thereafter if there are no current licenses installed.
Selecting Yes starts the New License Wizard.

Problem: A valid license could not be found.

Click Yes to manage your license(s) now.

Click No to close CCES.

Solution: This message appears if licenses have expired. Selecting Yes opens the Manage Licenses dialog box.

Problem: There was a problem installing the license for this serial number. Reason: Invalid license file. The license file may
be obsolete, corrupted, missing, or read-only.

Solution: This message indicates a problem with the license.dat file. For example, the license file is a VisualDSP++
license file that is incompatible with CCES. Check the contents of license.dat located in

<system drive>/ProgramData/Analog Devices/CrossCore Embedded Studio (on Windows Vista, Windows 7, and Win-
dows 8)

Also ensure that the file is not read-only. If the problem persists, contact Technical Support.

Problem: There was a problem installing the license for this serial number. Reason: A valid Host ID could not be found.
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Solution: Host ID information for your system can be found through the Manage Licenses dialog box in the CCES
IDE via Help > Manage Licenses > Report or Help > Email Support.

Licenses locked to an Ethernet (MAC) address require a physical TCP/IP network address to be available on the
computer. This error can occur if there is no network card installed.

Licenses locked to a disk serial number require a valid volume serial number. This error can occur if there is no C:
drive installed, for example.

Corporate domain licenses require that the computer be on a domain. Refer to Determining Your Corporate Do-
main for more information.

Problem: There was a problem installing a license for this serial number. Reason: The serial number has already been used
and can be installed only once.

Solution: The serial number you are trying to install has been installed already on this computer. For further infor-
mation, refer to Licensing Terminology.

Problem: There was a problem activating the license. Reason: There was an error during activation. This may be due to
the following:

• network outage

• firewall blocking access to the ADI activation server

• maintenance of the ADI activation server

Solution: This can occur during one-step activation. First, open a Web browser and confirm that you can open the
http://www.analog.com URL without any network or firewall problems. Then try activating the license again in the
New License Wizard. If you were on the last page of one-step licensing activation when you closed the error dialog
box, just click Finish again to complete activation.

If you still are unable to activate the license through one-step activation, on the Select license activation method page
of the New License Wizard, select the Install a temporary license and then register it via website option. Follow the
License Registration Instructions to register and validate your license.

Problem: There was a problem registering the license. Reason: The license has already been registered the maximum num-
ber of allowed times. Details: Registration limit exceeded.

Solution: Full and evaluation licenses can be activated a limited number of times. Contact Technical Support with
your current serial number, and we will help to activate your current license or issue a replacement license, depend-
ing on the circumstances.

Problem: The license was successfully installed, but there was a problem completing on-line validation. You can register
and validate your license manually by selecting Help > Manage Licenses.
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Solution: The Manage Licenses dialog box lists the installed licenses. See License Activation Methods for more infor-
mation.

Problem: The license file was successfully installed, but there was a problem opening the registration Web site.

Solution: This can occur due to a browser problem, for example. The Manage Licenses dialog box lists the installed
licenses. See License Activation Methods for more information.

Problem: There was a problem validating the license. Reason: The validation code is invalid. Please re-enter the code,
ensuring that you type the code EXACTLY as you received it. It might be helpful to copy-and-paste your validation code
rather than typing it manually.

Solution: CCES detected that you entered an invalid validation code. Ensure that you have entered the correct vali-
dation code exactly as given.

Validation codes are valid for a particular combination of serial number and host ID. If you are trying to install your
serial number on a different computer than the one you initially registered, you need a new validation code. Refer to
License Types for details.

Installation Warning Messages
This section describes common warning messages issued during license installation and validation. These messages
display in message boxes, dialog boxes, the Console view, and the command prompt.

Warning (in message boxes): <serial number> expires in x days

or

<serial number> expires today

Solution: If the given license has not yet been validated, it is in its grace period and will expire in x days (or today).
Refer to Validating a License for details.

NOTE: An evaluation license that has been activated also displays this message as it reaches the end of its life.

Warning (in dialog boxes): The Subscription Expiration dialog box appears at startup if any license subscriptions are due
to expire soon.

Solution: To prevent the re-display of messages for these licenses, select Do not show this message for these licenses
again and click OK.

Warning (in the Console view or command prompt):

[Informational ea1154]
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License to use this tool will expire in x days

Solution: The assembler has detected that your license will expire in x days. If you have an evaluation license or a full
license, register and validate it.

Installation Warning Messages
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